Follow

Compact Android Requirements

With all the combinations of device models and software variations, confirming device compatibility can be a daunting task. There are a handful of key requirements that your device must meet in order to run the Seek Compact imager and accompanying app.

  • Android version 4.3.x or newer - If your phone is running a later version of Jelly Bean, or any version of Kit Kat or Lollipop, your software should be fine. 
  • Powered USB On The Go - Not all Android devices can run USB peripherals. If your phone can connect to a USB hard drive it should be able to support the Seek Compact imagers.  Please be advised that some Android devices support USB OTG, but don't provide power to the attached peripheral.  If this is the case you will need a special cable that can connect to an alternate power source.  For more information, click here.
  • Micro-USB port - The port used to charge your phone or connect it to a computer must be the small, flat looking USB connector.  If you have a newer device with a USB-C port, there are adapters that will work.  For more information, click here.
  • Micro-USB position - For optimal use the imager should sit along the bottom of your Android device and point away from your phone's screen. If your USB port is on the bottom of your phone, and the wider portion aligns with the back of your phone, your port is optimal. If the port is reversed, or if it is on the side of your phone, you may still be able to use the camera with a micro-USB extension cable or adapter.

If you still aren't sure, file a ticket and we'll try to find more information. 

 

 

Was this article helpful?
5 out of 7 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk